Built-In Sample Compositions using Displace With Image Bug Alpha 3

Steps causing the bug to occur

1.2 is still in alpha so I don’t know if it’s a bug but all the 3 built in sample compositions using Displace With Image bug on 10.10

Make Rugged Terrain and Dent Room almost don’t show at all and sometimes glitch, displace Radial show up false on start; then disappears when values are modified to never shop up again.

This seems to be the case wether with the port set to luminance, RGB or alpha.

Included 3 movies of the compositions

How did the result differ from what you expected?

Have you found a workaround?


Other notes

  • Vuo version: 1.2.0-alpha1
  • macOS version: OS X 10.10

Displace With Bug.zip (695 KB)

Hi, @bodysoulspirit. Hmm, Make Rugged Terrain and Dent Room are working fine for me with Vuo 1.2-alpha3, using OS X v10.10 and an NVIDIA GeForce GT 650M GPU.

Which GPU are you using on this system?

On the same system, could you test those example compositions using Vuo 1.1.1 — do they still flicker?

(Regarding Displace Radial Gradient — that’s a separate issue; in 1.2 we changed the way displacements are calculated, but hadn’t updated that example composition to compensate. I just fixed it.)


They work fine in 1.1.1 !

I have redownloaded Vuo 1.2a3 and the bug still occur.

I’ve joined another video from the whole stuff, screenshot of the about this mac window and screenshot of the GPU info (it’s french).

I’m ok with the fact that displaced radial displaces differently as in 1.1.1. but I still think it’s related here as it first displaces the grid too high, it shows, but when I change the displace value from f.e. from 1 to 0,2 the grid disappears and doesn’t show up again (I’ve refired).

At the first glance it looks to work, but as soon as a change happens (moves) it disappears. Make Rugged Terrain and Dent Room have this is common that they move.

Don’t know …

Make Rugged Terrain Bug.zip (1.57 MB)

About Mac.png

Hey guys !

Just redownloaded Vuo (alpha 3) after my fresh install of OS X 10.11 El Capitan … And that fixed this bug … Well, actually partially !

  • The files open and the scenes loads and shows, no more glitches (which was the very first reported bug here).

  • But still I find the Vuo “Displace Object with Image” much smoother until 1.1.1 on my computer ! For example, I’ve just modified the “Make Rugged Terrain” sample composition by replacing the Orthographic Camera with a draggable Camera.

In Vuo 1.1.1, dragging and spinning the terrain was smooth. Here, it’s very choppy and laggy :(
I think displaced objects with images would also be smoother to be rotated for example (with a Interpolation Curve for example).
So far, the thing I do is to open the files Using Displace Object with Image with Vuo 1.1 even if they were created with Vuo 1.2 and then they run smooth.

I join the modified Make Rugged Terrain Composition, perhaps you guys could try a shot and see if you see any performance difference between Vuo 1.1 and 1.2 running it.

MRT.zip (45.2 KB)

We’re having trouble reproducing this — on all the systems we’ve tested, “Make Rugged Terrain” runs quickly and smoothly.

It seems like this problem may be specific to your GPU. Could you help us narrow it down? Please download Vuo 1.1.1, and all 3 of the Vuo 1.2 alpha versions, run “Make Rugged Terrain” (the original version, without the draggable camera), and measure the framerate (see the instructions here). If you can tell us the framerate on your system for each of those 4 Vuo versions, we might be able to figure out which changes slowed it down.

@smokris Hi Steve,

I have downloaded Vuo 1.1.1 - until 1.2 alpha 3.

On my new clean install of OS X 10.11 I cannot open Vuo 1.2 alpha 1 & 2 (crashes on startup), I can only open 1.1.1 and 1.2 alpha 3.

Made the tests with OpenGL Profiler and joined the screenshots here.
However, average Frame Rate never shows up and … both the original built-in Make Rugged Terrain seem to run at same speed (around 30 fps).

I’m also joining 2 videos of my modified Make Rugged Terrain with Draggable Cameras with the visible mouse clicks as well.
In Vuo 1.1.1 you can see how fast and smoothly the terrain moves, check how laggy it’s moving in 1.2a3. It’s choppy and continues to move when the mouse is stopped.

As for now, I’m experiencing several bugs that seems to affect only my specs / GPU card or I don’t know what it is. If I resume :

1 - Meshes running on the CPU instead of the GPU See that Bug Report.
I even just opened the Add Noise To Clay in Vuo 1.2 alpha 3 and ran OpenGL Profiler. Add noise to clay is now running at 107 % CPU usage at a framerate of ± 6 fps (see screenshot).

2 - Unable to move or rotate some elements using Displace Object With Image in Vuo 1.2 alpha 3 (this bug report commented here).

3 - Lagging compositions at startup See this Bug Report.

I Really wonder if :

a - It is affecting all the Mid 2011 Mac Book Pro’s (other users ?) or only my computer that would have an internal bug ?!

b - It these 3 bugs mentioned above are actually 1 bug, which is Meshes rendered on the CPU instead of the GPU ?!

I hope it only affects my machine and not all Mid 2011 macbook as that would mean quite a lot users, but even if it’s only mine I’m sad because these are annoying bugs :(

I may eventually be asking on the Vuo Facebook group if anybody has the same machine and ask if some tests could be done to verify so.

1.1.1.zip (38.2 MB)

1.2 a3.zip (26 MB)

Add Noise To Clay.jpg

Alpha 4 solved this for the MBP Intel HD 3000.
I will test this on an ATI iMac in december.

@bodysoulspirit reports this is resolved.

Solved for both the Intel HD 3000 and the ATI Graphic cards.