Composition can't keep up with OSC messages sent from NI Mate

Steps causing the bug to occur

See Kinect with Vuo 1.2.3 from @EDreams. A composition that receives OSC messages from NI Mate for skeletal tracking and draws a shape at each joint is unable to keep up with the ~1000 messages per second.

Have you found a workaround?

In NI Mate, disable Leap Motion tracking (OpenNI > Skeleton Tracking and uncheck the “Hands” section).

Other notes

  • Vuo version: 1.2.3

Filter Skeleton node added in Vuo 1.2.4 to solve this problem.