Composition Loader Crashing - Image Generator Protocol

Hello

All of a sudden my vuo composition loader has started crashing.
I’ve restarted my machine and reinstalled VUO and it’s still happening.

I’ve noticed that this is happening only when I’ve activated the image generator protocol which is weird.
I took an example composition, the exploding clay scene and tested it both ways and the composition loader always crashes on the version I’ve activated the protocol).

Because this has only started happening today I’m assuming it might be something to do with the clean my mac app which I ran earlier, but it’s never caused me any problems before. I also added some nodes into the module folder earlier (Ive taken them out now) and wondered if I could of moved something important.

Really not sure why this is happening, any help would be appreciated. I’ve attached a crash report if that’s helpful.

01renderinwindow.vuo (16.1 KB)

02renderscenetoimage.vuo (16.5 KB)

crashreport.rtf (65.7 KB)

Maybe Vuo’s cache has gotten corrupted. Go to your ~/Library/Caches/org.vuo folder (in Finder, go to the Go menu and hold down Option to the get to the Library folder, then navigate to Caches > org.vuo) and delete the 1.2.6.40 folder. Then launch or restart Vuo. Does that fix it?

If not, it might help to see more crash reports. The one you posted didn’t happen to catch Vuo doing anything interesting/incriminating, but sometimes if you capture multiple crash reports some are more revealing.

That did the trick, good to know, thank you!

Interestingly I just tried to reload these modules again (pictured) and the same thing happened again. The modules work fine but the loader crashes for me only when I’ve activated the image protocol.

Deleting the cache and removing those modules from the user modules folder has fixed it.

Does it still happen if you skip installing stv.makeWIndowProperty.vuonode (and rebuild the cache)?

It doesn’t, the doors back open, Thanks! :)