Crash when connecting Requested frame to Gradient Noise 1D Simplex

Steps causing the bug to occur

  1. Create a composition with Gradient Noise 1D
  2. Connect the Value of the Gradient Noise to a Make 3D point
  3. Add a Render Scene to Window
  4. Connect the Requested Frame to the Position of the Gradient Noise

How did the result differ from what you expected?

Application hangs then quits when connected

When did you first notice this bug?

When creating a compositon with a sphere that uses noise to control the position of a sphere

Have you found a workaround?

No.

Other notes

  • Vuo version: 0.5.0
  • macOS version: OS X 10.9

With the attached composition it will load and run without issue. If you disconnect the connection between the Render Scene to Window and the Make Gradient Noise 1D Simplex and attempt to connect it again the viewer crashes and the editor hangs.

SphereNoise.vuo (5.14 KB)

VuoCompositionLoader_2013-10-25-131251_macbooks-MacBook-Pro.crash (49.1 KB)

Vuo Editor_2013-10-25-001650_macbooks-MacBook-Pro.crash (52.5 KB)

VuoCompositionLoader_2013-10-25-000438_macbooks-MacBook-Pro.crash (51.8 KB)

VuoCompositionLoader_2013-10-24-235233_macbooks-MacBook-Pro.crash (51.7 KB)

VuoCompositionLoader_2013-10-24-234929_macbooks-MacBook-Pro.crash (47.4 KB)

VuoCompositionLoader_2013-10-24-234759_macbooks-MacBook-Pro.crash (52.2 KB)

VuoCompositionLoader_2013-10-24-234619_macbooks-MacBook-Pro.crash (49.4 KB)

VuoCompositionLoader_2013-10-24-233631_macbooks-MacBook-Pro.crash (51 KB)

Vuo Editor_2013-10-24-233306_macbooks-MacBook-Pro.crash (61.7 KB)

Vuo Editor_2013-10-24-230325_macbooks-MacBook-Pro.crash (61.7 KB)

VuoCompositionLoader_2013-10-25-132951_macbooks-MacBook-Pro.crash (53.2 KB)

VuoCompositionLoader_2013-10-25-132707_macbooks-MacBook-Pro.crash (51.9 KB)

VuoCompositionLoader_2013-10-25-132329_macbooks-MacBook-Pro.crash (54.9 KB)

VuoCompositionLoader_2013-10-25-131251_macbooks-MacBook-Pro.crash (49.1 KB)

VuoCompositionLoader_2013-10-25-130948_macbooks-MacBook-Pro.crash (52.9 KB)

VuoCompositionLoader_2013-10-25-004828_macbooks-MacBook-Pro.crash (48.9 KB)

@destroythings: We haven’t been able to reproduce this issue. Is it still happening for you with Vuo 0.5.3?

@destroythings: We believe we’ve fixed this issue in Vuo 0.8.0 (specifically, the crashes that say Application Specific Information: abort() called). Let us know if you notice it happening again.

Seems to be working fine for me now.

Thanks.