"export app" clash

Steps causing the bug to occur

  1. open a composition
  2. export “Mac App”
  3. clash

Other notes

  • Vuo version: 2.3.0
  • macOS version: macOS 11
  • How severely does this bug affect you? Not much; I’m just letting you know about it.

It was not possible to export with ver2.3.0.
I was able to export with ver2.2.1, but I could not start the app.

in v221

  1. open a composition
  2. export “mac app” → complete
  3. start app(double click) → clash

i couldn’t find “Vuo” file in DiagnosticReports folder.
so i instead attached some “clash report”.

_vuoVjMod.zip (131 MB)

@vjsatoshi, sorry for the trouble exporting. Thanks for such a thorough bug report, which even has a matrix of crash reports :-)

With Vuo 2.2.1, any exported app containing Syphon nodes will crash on launch. We fixed that bug in Vuo 2.3.0.

With Vuo 2.3.0, I think the crashes are related to subcompositions. Exporting an app from a composition containing subcompositions may be entirely broken in this version :-( We plan to fix that in the next release.

If you also see crashes when exporting an app without subcompositions in Vuo 2.3.0, please let me know.

I just had the same problem. Crashes on app export in 2.3, fine in 2.2.1.
Yes, the compositionI was exporting has one subcomposition.
I tried export with another composition that didn’t have any subcompositions and it worked.

As per my last message. Removed the subcompositions and the export to app worked.

Vuo 2.3.1 fixes the crashes when exporting a composition that contains a subcomposition or custom node.