Floating node library window sometimes won't re-dock in composition editor windows

Steps causing the bug to occur

  1. Open Vuo Editor
  2. Node Pallet is disconnected from Editor
  3. Try to drag title bar of Library Pallet onto side of Editor
  4. Pallet will not connect
  5. Closed Vuo & Trashed Preference files with no change in outcome

How did the result differ from what you expected?

I expected to be able to re-connect the Library Pallet to the Vuo Editor

Have you found a workaround?

No

Other notes

  • Vuo version: 1.2.0
  • macOS version: OS X 10.9

Running 1.2, 10.9.5

Double-click the library title bar.

Thanks @MartinusMagneson! I remember being able to hover the pallet and it reconnect.

Thanks @MartinusMagneson! I remember being able to hover the pallet and it reconnect. Also I trashed .plist files and it didn’t reset to defaul. Where do they live now?

I have no idea about the plist. There is a hover function, I have however also had great difficulty in making it work so I just resort to the double-click method.

We know of 2 situations where the node library can’t be re-docked by dragging/hovering:

  1. if the node library is already floating when Vuo Editor is launched, or
  2. if you float the node library from one composition editor window, then try to dock it to a different composition editor window

In both of these situations, double-clicking the floating node library’s title bar will re-dock it. (Thanks, @MartinusMagneson!)

I’m marking the bug report accepted, to cover improving the UX in those 2 situations.

Regarding plists: starting in Mac OS 10.9, the OS aggressively caches plists — so it’s no longer effective to simply delete or directly edit any ~/Library/Preferences/*.plist files. Instead, you need to use the defaults Terminal command. To trash all of Vuo’s preferences, you can do defaults delete org.vuo.Editor.

2 Likes

Ehh! OS X why cashe why?! :-(

1 Like