Get Mesh Values Node / Scale

@khenkel Having problems running the updated node set in vuo 1.2.5 and 1.2.6 alpha. Says Problem Running Composition, check that your nodes are installed correctly. I’ve rolled the parabox node set back to the previous build and the composition will run again. Just wanted to let you know. macbookpro osx 10.10

I bet you might need to take the composition, delete the old parabox nodes, and then swap in new ones from the node library. Not sure if it will help, but I’ve had something similar happen, and that worked.

BTW, thanks again for this node set, Karl!!! It’s really great.

You (or anyone for that matter) might be interested in some of the things going on in this editor; just saw it a couple of days ago and was impressed at some of the ideas for GUI objects that pop up to make enhance editing.

1 Like

@George_Toledo Thanks for the tip. However, it did not fix the issue. I’ll test on another machine that has a more recent version of OS.

@Khenkel I see the Get Mesh Values has been updated to include Transform. Thank you much! Now if I could just get it working. ha!  

@khenkel Same behavior in OS 10.11. Vuo 1.2.6 alpha. MPro. Get Mesh Values node is the culprit. Looks like all of the other nodes are working properly.

@krezrock yup same for me, no more Get Mesh Values since Vuo 1.2.6.a1

Thanks for the heads up, I’ve updated the nodes for 1.2.6.

1 Like

@khenkel odd. still can’t run the composition when placing the Get Mesh Values node in a composition. @bodysoulspirit Have you attempted to run these updated nodes?

1 Like

@Bodysoulspirit Have you attempted to run these updated nodes ?

Just tested the Get Mesh Values node and I still get the “There was a problem running this composition” error even with a blank new composition with only that node.
But from the history of the updates on Github it seems several nodes have been updated 2 days ago but not this one (latest update 2 months ago).

I hope the update will also fix the bug when the node is used to retrieve the vertices from Meshes that are being deformed by Add Noise to 3D Object which bugs since 1.2.4 (ran fine in 1.2.3, since the update of the Add Noise To 3D Objects in 1.2.4 to support noise deformation for points perhaps).

Oops, didn’t test with filtered meshes. Sorry!

The crash is fixed for the 1.2.6 release, and the node set has been updated (though it still won’t work until 1.2.6 is available).

@khenkel Sounds good. Looking forward to using the updated nodes in the 1.2.6 release.

Karl, downloaded the latest from Github, replaced the old ones in the user nodes folder, still getting this, anything I would need to delete somewhere ?
Vuo 1.2.6 and a fresh composition with only your get mesh node …

Was not sure I downloaded the last version so I downloaded them again from your link on the 1.2.6 update on Github and still have the same.

So the previous version of Get Mesh values had an “Element Assembly Method” port that is gone in the last version am I right ?

Element Assembly Method is new.

On the errors, it looks like I used the wrong magical incantation to pull mesh data back from the void. It’s fixed, and I’ve updated the node library on Github.

1 Like

Thanks @khenkel !

Seems to work great now ! Thanks !!

1 Like

@khenkel Great work as always. will download and move forward on a patch I’ve been stuck on.

1 Like


I get the “There was a problem running the composition” error using “Get Mesh Values” in Vuo 1.2.7.
@khenkel, does the plugin need to be recompiled for 1.2.7?




@cremaschi, are you sure that Get Mesh Values is the problem? And you have the latest version of co.parabox.nodes.vuonode? I was able to run a small composition containing Get Mesh Values in Vuo 1.2.7.

Hi dear,
I tested again, with your simple composition too, I get the error. I checked, and both vuo and nodes are updated to the last version.

I notice now that my “get Mesh Values” doesn’t have the “Element assembly method” input, so it should be a previous version.
I investigate deeper how this could happen - an I right downloading the last version from as reported in this thread?