Long topics login, website cache, long topics navigation

Steps causing the bug to occur

When I try to log in to submit a comment on a long forum topic (> 1 page, the node redesign topic f.e.), logging in pushes me back to the first page of the topic, and under Safari (v 9.0.3), I get automatically logged out when trying to reach other pages of the long topic.
So it’s, impossible to comment.

I’m adding another thing I’ve seen quite often, the fact that I need to refresh the website to get an up to date version of it, else I get some kind of an history version.
For example, I could power-up the computer, open safari, go to Vuo.org, and let’s say google search to go to Jaymie’s user page to see when she last logged-in.
It would be written 10 hours back, but only when I would refresh the page, it would show up 2 hours for example.
Same for recent comments on topics if I’m right.
Had not mentioned this earlier because was not sure if this could be some normal behavior. Tested on safari for iOS, and had the same.

Just another thought regarding long topics with several pages, the navigation links (first, 1,2,3 last) are on the bottom of the page, which means when you want to navigate to other pages, you have to scroll down, but if they are many images that are still loading, the page keeps moving and moving until all images are loaded. So you have to wait before you can navigate.
Perhaps the links on the top of the page, right aligned could be something ?
Would not be very beautiful, but perhaps handy. Only shown if several pages exist ?

Other notes

  • macOS version: OS X 10.11
  • How severely does this bug affect you? Not much; I’m just letting you know about it.

Video (lowD for faster upload) of the login thing on long topics.
Comment long topcis Login.zip (6.19 MB)

Mmm, and now it suddenly worked !
Either it is inconsistent, or you just fixed something !

Realized the post comment bug could be related to the load cache version of website one. Perhaps it shows I’m logged out while I’m logged in, should have tried to reload the last topic page after logged in but now the bug didn’t happen ;)  

When I try to log in to submit a comment on a long forum topic (> 1 page, the node redesign topic f.e.), logging in pushes me back to the first page of the topic

Thanks for reporting this bug. As you noticed, it’s now fixed :)

and under Safari (v 9.0.3), I get automatically logged out when trying to reach other pages of the long topic. I’m adding another thing I’ve seen quite often, the fact that I need to refresh the website to get an up to date version of it, else I get some kind of an history version.

Both issues are because of caching. Your browser is showing a cached version of the page instead of the latest page.

Safari 9.0.3 actually shows cached pages when it shouldn’t, due to a bug that was recently fixed, but unfortunately isn’t yet available in a build included with macOS or iOS.

In the meantime, you can manually refresh pages or use a different browser.

Just another thought regarding long topics with several pages, the navigation links (first, 1,2,3 last) are on the bottom of the page

OK, the links now appear at the top and bottom of the comments section, right-aligned.

1 Like

Cool ! ;)