Make Fisheye Camera not showing image output

Steps to reproduce the bug:

When running the example compositions “Show Trees with Fisheye” or “Move through Tube with Fisheye” , i do not see an image output.
The nodes “Make Fisheye Camera” and “Make Targeted Fisheye Camera” seem to render (when i hover over the output port, i see the node executes at display refresh rate), but does not show any image output.

Have you found a workaround?

No. When i replace the Fisheye cameras, with Perspective Cams, i see an image output with the example comps.
I tried deleting and reinstallung Vuo, and i reinstalled my pro license, but the issue persists.
When i run the compiled demo app from this post, (Make Fisheye Camera Demo) i get an image output. No output when i run the composition from the editor in composition loader…

Other notes

  • Vuo version: 2.4.4 (12009)
  • macOS version: 14.3
  • Mac model and CPU: MBP (M1 Max)

I can confirm the trees demo doesn’t work for me either.
Sonoma 14.2.1, Intel macmini
Vuo 2.4.4

1 Like

Please see the attached simple demo, connecting the targeted perspective camera works, the targeted fisheye does not. I’ve used this fisheye node in the past, so something has recently broken.

fisheyetest.vuo.zip (1.4 KB)

See attached, target seems to be ignored.

Thanks very much for letting us know about this bug, @09.arcs-wrap. And thanks for your testing, @pbourke.

We’ve confirmed that the Make Fisheye Camera and Make Targeted Fisheye Camera nodes cause Render Scene to Window to output all black. We’ve identified the cause — a problem with the way these particular nodes check for a Vuo Pro license, which was an unexpected side effect of a change to the Vuo compiler in Vuo 2.4.3 — and will work on fixing it.

As a workaround until then, you could use Vuo 2.4.2, which you can find under Vuo releases. Apologies for the inconvenience.

1 Like

Fixed in Vuo 2.4.5.

1 Like