Motion, FCPX crash immediately when trying to use any Vuo-exported filter.

Steps causing the bug to occur

  1. recreate Frosted Glass FxPlug following YouTube example exactly. (or custom)
  2. Save Vuo / Export FxPlug
  3. restart Motion or FCPX - drag filter found in Effects: Vuo: (Frosted Glass)
    (( doesn’t matter if applied to group or image, etc. same result. ))
    on release Crash.

Have you found a workaround?

nerp. have tried uninstall-reinstall.

Other notes

  • Vuo version: 2.0.3
  • macOS version: macOS 10.14
  • How severely does this bug affect you? It prevents me from completing a specific task with Vuo.

Motion_2020-06-23-133035_Ryans-MacBook-Pro.crash (196 KB)

Frosted.vuo (1.59 KB)

Final Cut Pro_2020-06-23-124018_Ryans-MacBook-Pro.crash (169 KB)

Motion_2020-06-23-121352_Ryans-MacBook-Pro.crash (181 KB)

Ryan,

We traced the problem to a missing file, but we’re not able to figure out why it’s not being included in the Plug-in. If you could ZIP and upload the exported FxPlug, we’ll inspect it to see how it differs from a working FxPlug, which might give us some clues on how that might happen. We’re also putting some debug code into our next release, and we’ll contact you when that release is out.

tried w 2.1.0.11405 same result.

uploaded .zip contains Frosted.fxplug, and Motion Template (following Finder link from export success window) - although i notice isn’t making a folder with the moef, but a Package instead. not sure if that matters.

Frosted.zip (3.56 MB)

Ryan,

The plug-in works fine for us. We wonder if it’s some type of interference with some of your other 3rd-party plugins. Could you temporarily remove them, and see if the problem resolves? If it is interference, and you can narrow down what plug-in(s) are causing it, we can hopefully figure out why that’s happening and fix it.

We haven’t been able to reproduce the problem. @RyanWelborn, if you can provide any info that would help with troubleshooting (see @jmcc’s comment above), let us know and we’ll reopen the bug report.