Persistent OSC connection

Currently I receive OSC from touch OSC on my iPhone. In vuo I use the receive Osc node and set device to auto.

When I run the comp I can select it in touch Osc and it works great.

However when I click on device on the Receive OSC Message node, I can select my iPhone - but it doesn’t pick up messages.

What a I missing?

It’s clear something can get through, but is it possible that my router is interfering with UDP? And if so, how can it see the device as an option, but nothing else?

Figured it out. First, List OSC Devices → Specify OSC Input → Receive OSC Messages.

Change the port in Specify OSC Input to the outgoing port in TouchOSC (default was 56708). Now the OSC connection stays alive after stopping and starting.

Screen Shot 2021-09-09 at 11.30.54 AM.png

Great! Glad you got it working.