Publishing Torus "Columns" port causes glitchiness in Image Generator

Steps causing the bug to occur

  1. Process a list of tori in an Image Generator comp
  2. Publish the “Columns” port


Process a list of tori in a subcomposition with the “Columns” port published.

How did the result differ from what you expected?

I expect no rendering issues to occur when I publish the “Columns” port.

Have you found a workaround?

No luck – tried inputting a list of integers for columns, tried creating a list of tori with different column settings. Besides that, the normal comp works when not in the Image Generator protocol or subcomp.

Other notes

  • Vuo version: 1.2.1
  • macOS version: OS X 10.11

What happens: there is a glitchy gap/missing tori when the number of copies gets higher than 18 or so.

I am thinking another approach might be to use Make Parametric Points, Line Strip, etc., but this seems like more overhead compared to the Torus. (The entire reason I am using the Torus is to get lower count polygons. Besides that, the comps are really 2D graphics).

ConcentricTori_IG_glitchy.vuo (8.63 KB)

ConcentricTori_works.vuo (8.55 KB)

@jersmi, it’s basically the same problem as on How to animate torus thickness? — there need to be Hold Value nodes in there to prevent the event streams from the published input ports from entering the Process List loop at odd places. See attached composition.

I’m marking this “Not a bug”, but it’s clearly a point of confusion for you and others, and Vuo should not be confusing. I’m hopeful that the feature request Allow changing single-value ports to accept lists (turn most nodes into iterators) will provide a method for iteration that doesn’t require so much meticulousness about event streams.

ConcentricTori_IG_glitchy-fixed.vuo (8.91 KB)

Embarrassed… well, I’m learning! Didn’t even think to try the Hold with Columns… Apologies, my process is very messy at present.