Save to movie with overwrite on keeps previous resolution

Steps causing the bug to occur

  1. Use a save to movie node to create a movie file.
  2. Change the resolution and record a new movie with the node set to overwrite
  3. Resolution will still be like the previous recording

How did the result differ from what you expected?

Resolution should change in the saved file as well

Have you found a workaround?

Delete the file manually, and re-record.

Other notes

  • Vuo version: 1.2.1
  • macOS version: OS X 10.10

Soundflower (2ch) was used for audio

Hmm… After trying some more, I set it to 1920 x 1080. After recording it was 2048 × 1536 pixels. Stopped it, deleted the file and started it again. Then it was 1920 x 1080. Stopping and deleting and starting again set the resolution to 640 x 480 again. I have no idea where these resolutions come from. The input to the save to movie node reports an image that is of the size I’ve set it to be in the window properties.

I’ve tried inserting a resize image node in front of the image input of the save to movie node now that seems to work.

Hm, I tried it but am not seeing the problem. See attached compositions. Magneson, do you know what’s different between your compositions and mine? If not, could you post a small/simple composition illustrating the problem?

I have no idea where these resolutions come from.

Possibly relevant excerpt from the Save to Movie node description: “Certain characteristics of the movie are determined when saving starts, and can’t be changed while saving is in progress. The width and height of the movie are determined by the first image received.”

ChangeMovieSizeBetweenRuns.vuo (2.34 KB)

ChangeMovieSizeDuringRun.vuo (4.61 KB)

The width and height of the movie are determined by the first image received."

The weird bit about it was that the resolutions were of such a size that nothing else in the composition even included the numbers. It seemed like there were multiples of a resolution or something like that. I can’t reproduce it in the composition I believe it happened in now, but I was feeding the Save to Movie node with a size that showed up in the popover as expected, but when checking the movie afterwards, the size were completely different. This difference weren’t consistent either, as sometimes it would render at 480p, sometimes at 2k+, and sometimes in between.

If I stumble across it once more I’ll upload a composition. I strongly suspect it has to do with feedback or something like that, where the first image gets blown out of proportions before normalizing.

OK, I’ll go ahead and mark this “Not a bug”, but let us know if you find a way to reproduce it.