Selecting audio channels

How do I select from a number of audio sources?
I would normally use the “Select Input” node, which is what I do for movie frames.
But it won’t accept the decoded audio from the “Play Movie” node, nor will it accept the output from the “MIx Audio Channels”.
In essence I have N movie sources each with their own sound track, I need to switch between them with the audio being use in the “Send Live Audio” node.

If I understand correctly, I think it’s a bug I’ve encountered for certain nodes/data types where the Vuo Editor does not automatically select the right/new data type when connecting to a generic type port sometimes (could also be because one would have selected a different data type before and Vuo doesn’t auto change it (there is a request for that), so you have to revert it back to generic data type first).

So manually selecting the data type by right-clicking a port usually works (and revert it back to generic first if needed), joined comp


Select Audio.vuo (1.33 KB)

Thanks, that fixes it.
Also, just choosing a new node rather than duplicating the one I was using for the movies.
Didn’t know about the option to choose the input type also, so informative all round.

1 Like


The output from the Decoded Audio port of Play Movie is a list of VuoAudioSample elements, since you are receiving samples from multiple channels. So, you would use a Select Input node that operates on lists, such as Select Input List (8). Eventually (sometime post Vuo 2.0) we hope to make this easier by allowing Select nodes to accept both single elements and lists. Mix Audio Channels combines multiple audio channels into a single channel.

1 Like