The Composition Loader window cannot be moved or even activated when using 3d objects

Steps causing the bug to occur

  1. Open any of the examples in vuo.scene category (or anything that uses 3d objects)
  2. Run it
  3. You will notice that you cant activate the composition loader window to bring it to front.
  4. You can’t grab and move the window
  5. The “Make 3d Object” node seems to be what is causing it to happen

How did the result differ from what you expected?

I was expecting to be able to activate the window.

When did you first notice this bug?

Vuo 0.7

Have you found a workaround?

No

Other notes

  • Vuo version: 0.7.0
  • macOS version: Mac OS X 10.7

I’m using Lion (10.7.5) and I’m not sure if Vuo is properly supported for that.

I tested a bit more. It definitely is the “Make 3d Object” node that causes this to happen. Without it even connected to any other node. Haven’t found any other node that would cause this. I tried most of the 3d related nodes.

  1. Create a new composition
  2. Add “Render Scene to Window” node (or any other node that will create an output window)
  3. Add “Make 3d Object” node
  4. Do not connect the nodes together
  5. Run the composition
  6. You can’t activate or move the output window

Wow, that’s weird. We tried to reproduce the issue you described on several systems (including one running Mac OS 10.7.5) but haven’t been able to reproduce it yet.

We currently support (and testing) Vuo on Mac OS 10.6 and up.

A few questions to help us narrow this down:

  1. Could you confirm that the Render Scene to Window window works (can be activated and moved) if there’s no Make 3D Object node?
  2. Does it break if you use Display Console Window instead of a graphics window?
  3. Does it break on earlier versions of Vuo, or only 0.7.0?
  4. When was the last time you rebooted? Does it still break immediately after a reboot?
  5. Does it still break if you create a new Mac user account and run Vuo from that account?

Also, while it’s not responding, could you make a sample of the VuoCompositionLoader process (Activity Monitor > View > Sample Process > Save) and attach it here?

I was able to somehow get rid of this for a moment while messing with it now. Details below.

  1. Yes, that is what it seemed to do in my earlier tests. Only adding the Make 3D Object seemed to trigger this. But it seems to be a bit less consistent now. Sometimes it works, sometimes it breaks.
  2. Sometimes, it just seems that I need to add more of the nodes to get it to happen. Like 3-4 Make 3d Object nodes and the console window, nothing is connected
  3. Haven’t tested yet. I’ll try it out later.
  4. Just rebooted and it still behaved the same way.
  5. I’ll try this a little bit later
  • I have gfxCardStatus installed on my computer to be able to switch between which graphics card I use. Normally it’s on the Dynamic Switching mode where it automatically switches between the integrated and discrete cards.
  • I tried switching between the cards to see if this is an issue related to the hardware, but it happened with both of them.
  • I also quit the program to see if it was somehow related to that, but the issue still remains.
  • This does not happen 100% of the time. I’m able to sometimes get it working after trying multiple times.

Oh, and the composition itself runs just fine when it does this. I just can’t move the window, it locks itself to the bottom left corner of my computer.

I have attached three process samples while trying to run the example composition “Compare4Cameras”. I kept restarting the composition until it worked properly. So you’ll have a sample of it when it’s broken and when it’s working

  1. Using GeForce GT 650M – Broken
  2. Using GeForce GT 650M – Working
  3. Using Intel HD Graphics 4000 - Broken
  4. Using Intel HD Graphics 4000 - Working

VuoProcess_CompareCameras_GeForce_GT_650M_Broken.txt (1.97 MB)

VuoProcess_CompareCameras_Geforce_GT_650M_Working.txt (1.99 MB)

VuoProcess_CompareCameras_Intel_Broken.txt (2.01 MB)

VuoProcess_CompareCameras_Intel_Working.txt (2.06 MB)

Here is a video of what happens. You’ll notice that it doesn’t happen every time, but seems that the more of the Make 3D Object nodes I have, the more certainly the window locks.

I also attached a simpler process sample. Just the two nodes in this composition.

VuoSample_Simple_GeForce_GT650M.txt (72.1 KB)

I tried in Vuo 0.6.1 also. Couldn’t reproduce.

Here is what my console says when this happens:

5/1/14 10:11:26.358 PM VuoComposition-1ssCJf: _RegisterApplication(), FAILED TO REGISTER PROCESS WITH CPS/CoreGraphics in WindowServer, err=1003

5/1/14 10:11:26.358 PM [0x0-0x1ad1ad].org.vuo.editor: _RegisterApplication(), FAILED TO REGISTER PROCESS WITH CPS/CoreGraphics in WindowServer, err=1003

5/1/14 10:11:26.515 PM VuoComposition-1ssCJf: kCGErrorFailure: CGSDispatchDatagramsFromStream : No handler for datagram type 3

5/1/14 10:11:26.515 PM VuoComposition-1ssCJf: kCGErrorFailure: Set a breakpoint @ CGErrorBreakpoint() to catch errors as they are logged.

5/1/14 10:11:26.740 PM VuoComposition-1ssCJf: kCGErrorFailure: CGSDispatchDatagramsFromStream : No handler for datagram type 3

Thanks for the details, @mnstri.

Given the console messages you’re seeing, we suspect this might be related to the changes we made (in Vuo 0.7.0) in the way compositions initialize themselves (to fix this issue). We haven’t been able to make much sense of them yet, but we’re continuing to investigate. And we submitted a support request to Apple to see if they can provide any insight.

Two more questions:

  • If you “File > Export App” the same composition, then launch it from Finder, does it ever fail to activate / allow movement?
  • Could you try setting a breakpoint (like suggested in the console messages you pasted above), and provide a backtrace for that breakpoint? (Open Terminal, type gdb followed by space, then drag the exported app into Terminal, then press return, then type b CGErrorBreakpoint and press return, then type r and press return. It should then show the app window and give you another prompt, in which you should type bt then return, and q then return. Then attach the output here.)

Compositions that fail to launch properly from Vuo Editor work perfectly fine as exported applications.

So I guess I can’t test the breakpoint?

Hi, @mnstri. We believe we’ve fixed this issue in Vuo 0.8.0. Could you confirm whether it’s still happening for you?

Seems to be fixed. At least haven’t had it happen yet. I haven’t tested extensively, but in the previous version it would happen all the time.

Glad to hear it. I’m going to tentatively mark this resolved; let us know if you notice it happening again.