UI language not determined by preferred language

Steps causing the bug to occur

In System Preferences > Language & Region, set English as the first Preferred Language and German as the second Preferred Language, and set the Region to Germany.
Launch Vuo-2.0.0-beta1.
The Vuo UI should be in English now since that’s the first Preferred Language. Instead, it’s in German.

Have you found a workaround?

in System Preferences > Language & Region > Preferred Languages, remove German. (But you can keep Region set to Germany.)

Other notes

  • Vuo version: 2.0.2
  • macOS version: macOS 10.15
  • How severely does this bug affect you? It’s annoying but I can work around it.

While I can work around this bug, it really wrecks the user experience as the German translations are really weak.
The same bug was filed by someone else against Vuo 2.0.0-beta1 and reported to be fixed in 2.0.0-beta3. However, it is present (again?) in 2.0.2


We’re sorry you are having this problem. We’ve had two other users report the same issue. Unfortunately, we can’t reproduce it. Our next release will include additional information to help us debug this problem — we’ll follow up with you once that’s ready. We’re glad you’ve found a workaround. Thanks for letting us know, so we can make Vuo better.

Jean Marie, Team Vuo"


We’ve included additional debug code in release 2.1, and later. We would appreciate your help in solving this. Here’s what you need to do:

Open a new Terminal window, and paste these commands:

system_profiler SPInternationalDataType  
defaults delete org.vuo.Editor translation.enable  
defaults write  org.vuo.Editor debug -boolean true   
log stream --style compact --predicate 'subsystem == "org.vuo"'

Then launch Vuo. Vuo should show the incorrect language.

The Terminal window should fill up with a bunch of text. In Terminal, go to the command bar, Shell > Export Text As…, save it to a file, and attach that file to this bug report.

Then, select the Terminal window and press Control-C to stop the log viewer, then paste these commands to restore your previous configuration:

defaults delete org.vuo.Editor debug  
defaults write  org.vuo.Editor translation.enable -boolean false

Thanks for helping make Vuo better for everyone!

Jean Marie