Why does this smoothing composition work but not as a sub-composition?

I’ve unrolled a loop to process 25x 2D points to smooth their changing values. Takes a list and has a common duration, uses Smooth with Inertia node inside.

I loaded some data that is just a flip-flop of two sets of five (X,Y) points and it draws ovals centred at these flip-flopping points and smooths between them fine.

When I publish the inputs and outputs and saved into the Node Library it doesn’t work, is this event related? I’m still mystified by the whys and whens of events in Vuo… I lost the comp it was made from when I saved to Node Library (there should be a warning about that!) and had to recreate a working comp, building it up from scratch with bits copied at a time and it worked, was unable to get the Node Library version modified to work again as a stand alone. (Perplexing!!)

There is some weirdness at work… replacing a suspect node that wasn’t doing as I thought it should with a new node from Library worked in case of one oval out of five that wasn’t working.

As working composition moving objects around smoothly: smooth 2D points working.vuo (14.5 KB) N.B. this has no extra fire wires running to later nodes, it all fires off the Select Input List node event that fires periodically.

As not working sub-composition: useful design.smooth2Dpoints.vuo (22.7 KB)

Test rig for not working composition: Test rig for smooth a list of 2D points.vuo (401 Bytes)

Also, how do I change my username to note have a space in it when it makes sub-comps.
And why is it misnaming the node in the node library?

Looks like the underlying issue is the same as your other post — how events flow through published ports.

For the subcomposition title, it splits on camel case, so try smooth2dPoints.

I’ll check on the username and get back to you by email.

Cheers @jstrecker