Audio Device has no channels - Solved

Steps causing the bug to occur

After testing one of my old comps in Vuo 2.0 Beta it wasn’t working and so I quickly made this comp to breakdown where the issue was coming from. It looks like Audio Devices aren’t supplying their audio channels.

  1. Open attached composition
  2. Run composition
  3. Check “Channel Count” for “Get Audio Input Values” node
  4. Channel count is “0”

Other notes

  • Vuo version: 2.0.0-beta1
  • macOS version: macOS 10.14
  • How severely does this bug affect you? It prevents me from completing a specific task with Vuo.

You can’t use audio devices in Vuo until this is fixed.

Audio Issue - No Channels.vuo (1.04 KB)

Have you give Vuo access to the “microphone”? When you start an application that ask access to the audio interface, the OS will ask you, but will name it “microphone”: you have to say yes. Or it’s something else…



On my iMac, the 2 compositions behave the same it seems for both Vuo 1.2.8 & 2.0 beta, see screenshots, sure that is the issue ? Or are you seeing different results ?
I’m able to receive live audio from some old compositions running in Vuo 2


The thing I mentioned happens on macOS 10.14.


You’re right normally it does do that. I don’t recall it asking me when I installed Vuo or ran the comp.

OK, got back on the system I was having trouble with. Yep it was me. Vuo 2.0 was unchecked under Security Privacy>Microphone. I didn’t even see the popup window asking for authorization to use the mic. Weird. Anyway it’s working now.

Glad to hear that It’s working now.

I created a separate bug report for the question about Get Audio Input Values: