Comps with both uninstalled nodes & not updated for Vuo 2.0 freeze

Steps causing the bug to occur

  1. Open a composition that contains both uninstalled nodes (here a sub composition, don’t know about real Vuo modules/nodes) + 3rd party nodes that have not been updated for Vuo 2.0
  2. Not able to click ok, or cancel, or close or quit the Vuo Editor, you have to Force Quit it

Sample composition & video joined

Have you found a workaround?

Remove outdated 3rd party nodes

Other notes

  • Vuo version: 2.0.0-beta1
  • macOS version: OS X 10.11
  • How severely does this bug affect you? Not much; I’m just letting you know about it. (648 KB)

@Bodysoulspirit, so far I haven’t been able to reproduce this. If you are able to make it freeze again, could you please go to Activity Monitor, select the Vuo process, go to the gear menu and select Sample Process, and attach that sample here?

It’s not really that the Editor freezes, wrong words used, but more like it’s struggling to deliver the 2 notifications, cause when you right-click in the dock to quit it, you hear that macOS error sound.

Though, this is on mac OS X 10.11 and 2011 hardware, if this does not happen on more recent hardware / macOS versions, I wonder how much team time is worth putting into this, guess the user base is more up to date, I’m just waiting for better macs to update ;)

Vuo Sample.txt (107 KB)

@Bodysoulspirit — Was there, by any chance, another dialog open, perhaps behind the window or on another screen? That would explain the failure to respond to clicks and the macOS error sound.

Mmm. I don’t think so, it also happened several times / every times I tried opening one of those.

However I updated to macOS 10.13 and it somehow seems fixed ! :)

(I say “seems fixed” because the first time I tried I think it happened again, moved the modules from the modules folder, relaunched, but them back there again, relaunched, and now it works). Strange, but not 100% sure.

Anyway, works now I guess ;) Thanks for your time

However I updated to macOS 10.13 and it somehow seems fixed ! :)

Huh. OK. Thanks for letting us know.

If this problem crops up again in the future, we can reopen the bug report.

1 Like