Crash when opening compositions containing 3d models

Steps causing the bug to occur

  1. Start Vuo by clicking on comp containing 3D model (tested with various obj, fbx and dae).
  2. Crash, sometimes with crash report other times nothing.

Have you found a workaround?

It’s not consistently crashing but I have found opening the app and then the comp works most times.

After reading my crash reports (attached) and then removing Smokris Stochastic Camera Blur comp from my Modules folder it seems better…

Other notes

  • Vuo version: 2.0.0-beta1
  • macOS version: macOS 10.14
  • How severely does this bug affect you? It’s annoying but I can work around it.

vuo crashes (110 KB)


We think it’s possible that your bug report is a manifestation of a problem with some third-party nodes in Vuo 2.0. There is more information at: Could you please see if the procedure listed there fixes your problem? You thought maybe removing Stochastic Camera Blur comp from your modules folder fixed it. Did it indeed solve the problem completely? If not, can you please send us a 3D model and a composition that crashes for you?  

Thanks for the reply, on my first day testing Vuo crashed a lot so I removed all modules and had added some back in.

What I think I’ve realised is that I needed to restart my machine for Vuo modules folders to be read as empty. Is that correct?
It seemed to clear the issue until I tried opening 8 variations of the same test comp at the same time.
I’ve attached a few crash reports, the one marked green was after restart with no modules in any folders, and a pre-offending comp and model.

scene load crash (170 KB)


It is not correct that you need to restart your machine (or even Vuo) for the module folder to be read as empty.

In looking at your crash reports, if you moved your user module folder to the desktop, and then ran a composition from the desktop, the composition would see the modules folder, and treat the subcompositions and modules in it as composition-local, and load them. This behavior is covered in the manual under “Making a node available to one or a few compositions.”

We recommend you uninstall the Parabox nodes completely for the time being. We know there are issues with those nodes. There may be other nodes with issues as well, this is just the one set we know about so far.

So, please let us know if removing the Parabox nodes and not running compositions from the same location where you have a Vuo modules folder helps.

Thanks for clearing that up @jmcc. All good for now.

Would the best advice be ‘move and rename’ modules folders to get them out of the way?

Hope the Parabox nodes get an update asap. I have used them a lot! @khenkel  

Would the best advice be ‘move and rename’ modules folders to get them out of the way?

Or just just leave it in place and rename it to, say, Modules (disabled).  


@Scratchpole, see here for the list of known issues with community nodes in Vuo 2.0.0-beta1.

While your crashes did occur during the loading of installed nodes/subcompositions, based on my testing so far, I would guess that they’re not connected to any particular node or subcomposition. (I did briefly test smokris’s Stochastic Camera Blur and did not get any crashes.)

@Joe, are you still seeing any crashes? How about with Vuo 2.0.0-beta3? (Ideally Vuo itself shouldn’t crash even with outdated nodes installed.)

We’ve definitely fixed one kind of crash you were seeing. Not sure about the other kind.

Hey all good, just got around to testing with beta4. Happy new year!
Sorry for super delayed response, I was very busy at the time.

I’ve seen the other report on FB about model loading taking loads of memory and from my first quick tests there does seem to be some issues, will test more and get back to you.

1 Like

@Scratchpole, we probably fixed this in Vuo 2.0.0 :) At least, we fixed some related crashes, and we were able to repeatedly open a composition with the ~100 nodes that your crash report showed you had installed. If you do still see crashes, let us know.