Editor hang after typing word in node library text field

Steps causing the bug to occur

Type a word in the search field, then Vuo hangs.

I have a Belkin thunderbolt hub with a Dell U2715H external monitor attached (as well as two ext. hard drives). This problem happened only after I connected my MBP to the hub. I have only been using Vuo 10.2.1 without connecting to the hub, until yesterday. This is the only time this issue has happened with v1.2.1. I will try with monitor attached directly to computer asap.

Attached comp, though tried others and happens with all.

Have you found a workaround?

Reinstall Vuo Editor works for a few minutes, then hangs again.

Other notes

  • Vuo version: 1.2.1
  • macOS version: OS X 10.11
  • How severely does this bug affect you? It’s annoying but I can work around it.

This means I can only use Vuo when I am not attached to hub or with some hardware config I haven’t tried yet.

gif0.vuo (8.39 KB)

Sample of Vuo Editor1.txt (71.5 KB)

Sample of Vuo Editor2.txt (69.9 KB)

Problem persists, looks like it is related to my new monitor? Let me know if you need any other stuff from me. This is a bummer, like to figure it out asap. I am currently limited to using my laptop screen (or work computer, 4K iMac works great).

I disconnected the external monitor from the hub and connected it directly to my MBP, using thunderbolt cable that came with the monitor. I reinstalled Vuo, restarted, still hanging when I try to do anything in the Node Library.

I need to get someVuo comps into VDMX and see how things work with projectors…

I found that my pretty new OWC Thunderbolt hub was interfering with all my USB input devices for a second or two at a time they were dropping out. I’m running DisplayPort Dell 27" from the TB 2 port of the OWC or running to the RAID with TB and then Dell with TB from there. Both wirings working ok (now).

Same with USB 3.0 drives which caused them to unmount. Was about to return it and so tested with my old MBP and then it was fine. So tried again with new MBP and it seems ok some far (touch shader-wood-texture :-) ). Not sure if that is relevant to this, it wasn’t a Vuo issue was just a hob and USB dropout issue.

Ok, I thought I sorted this out by switching from Display Port to HDMI. Switching cables immediately fixed the issue. (Edit: HDMI bypassed the hub, plugged directly to computer).

I thought it had something to do with the Dell monitor’s DP (or my MBP’s mini display port, or the cable, etc.). I was using the DP to miniDP cable that came with the monitor, when I switched to HDMI, the Vuo node library started working again. (DP MST/HBR is new territory for me. While still connected from miniDP to DP, I tried switching back and forth from DP 1.1a to 1.2 on the monitor, no luck there. I would think VUO would be up to speed with Display Port protocol, MST, et al.?)

By the way, my specs: MBP Mid 2014, NVIDIA GeForce GT 750M 2048 MB

Then –
I disconnected the external monitor from my MBP, worked for 10 minutes or so and the problem came back.
Deleted preferences for the editor, deleted/reinstalled Vuo editor. Still happening.

Then I yanked my user Modules folder and my luck improved. (This somehow makes some fuzzy sense for something that would mess up the Node Library?) Now I put it back and thing are still ok.

Is there any way to troubleshoot the Modules folder without yanking one by one? I blame my own subcomps because they are most recent, but it has been a couple days since I added anything. Is there anything that could cause trouble?

@jersmi, the hang report shows that Vuo Editor is waiting on the compiler subsystem to process some subcompositions that you have installed. It seems unlikely that the display has any bearing on that.

If you wait a few minutes, does Vuo Editor ever recover from the hang?

If you uninstall all your subcompositions (Tools > Open User Modules Folder; move contents out of that folder) and restart Vuo Editor, does it still hang?

Do you see any messages in Console?

What I did was simply yank the modules folder then immediately put it back and it fixed the issue. I didn’t delete or change any subcomp…

From Console this eve:

3/4/16 10:49:13.166 PM Vuo Editor[58968]: VuoCompilerNodeClass.cc:1027 parseDetailsParameter() Error: Couldn’t parse vuoDetails for stv.GenParticleEmitterL: {“default”:{“x”:0,“y”:0,“z”:0},“suggestedMin”:{“x”:0,“y”:0,“z”:0},“suggestedMax”:{“x”:360,“y”:360,“z”:360}

I’ll pull it and see how things go.

I don’t think the “Couldn’t parse vuoDetails” is related to the hang. It’s just a warning that there’s a typo in the node source code that will prevent some input port from having the intended default value and slider range.

If you discover other items in your Modules that might be leading to the problem, let us know.

Closing this bug report until we get more information.