FFGL export not reading node


Have been playing around with Azy’s Connected Shapes Set (Connected_Shapes_Set), swapping in Bodysoulspirit’s Get Object Vertices node (Scene : Get 3D Object Vertices) for the Parabox Get Mesh Values node which I understand doesn’t work in Vuo V2.x.x (thanks to all for sharing their work here).

All this is working fine in the Vuo editor, but when I go to export the comp as an FFGL I’m getting an error message saying that the BSS node isn’t installed.

Am I missing something here?

As a (slow!) learning exercise I’ve tried compiling the .c module into a .vuonode one, and rebuilding the comp from scratch, but that didn’t make any difference.

Any tips would be appreciated!


We are aware of this problem and we are working on a fix for this. It’s related to the accepted bug report “export app” clash.

For the workaround until we fix this, you’re on the right track. You need to create an x86_64+arm64 .vuonode file. To do so, you’ll need the newest 2.3.0 Vuo SDK version from https://vuo.org/releases.

Once you’ve installed the SDK, use the example code at /Library/Developer/Vuo/example/node/stateless as a starting point.

  • Copy the stateless folder to your Desktop (or elsewhere if you’d like).

  • In that folder, replace example.stateless.vuoize.c with bss.scene.getvertices.c.

  • In CMakeLists.txt, replace the reference to example.stateless.vuoize.c with bss.scene.getvertices.c.

  • In Terminal:

       cd ~/Desktop/stateless
       mkdir build
       cd build
       cmake ..

Hi Jean Marie !

I tried your steps, but got an error in the terminal :) Either a bug, or as someone who really only starts to code, your code was just a snippet of the whole code and I thought it was the full code ? ;)
In the end it only adds an empty folder called “build” in the stateless folder beside the other files.

-bash: cmake: command not found
imac-de-bodysoulspirit:build bodysoulspirit$  make
make: *** No targets specified and no makefile found.  Stop.

EDIT 1 :
Seems CMake was not installed from reading the error since QT was not installed ?
So installed CMake manually, now Cmake version 3.20.3 installed, when I run your code into the terminal, it builds some files but no Vuonode (see screenshot).
Sorry for the dumb questions ;)

EDIT 2 :
Ok while the above terminal method still returns the error, I finally managed to build my first .c code into a .vuonode using QT (for that specific node : Scene : Get 3D Object Vertices).


Capture d’écran 2021-06-12 à 23.57.02.png


when I go to export the comp as an FFGL I’m getting an error message saying that the BSS node isn’t installed

Fixed in Vuo 2.3.1.