Images not displaying when using custom User Node in Library

Steps causing the bug to occur

  1. Load Custom User Modules into VUO (Provided in Zip file)
  2. Launch Convocation Master (3360x1080) v1.1 composition
  3. Play Composition (No images are displayed?!?)
  4. Stop Composition
  5. Double Click custom user node (Loyalist )ConvocationGUIto open it in the editor
  6. Play Composition (Images show up now?!? Why?)

Have you found a workaround?

Not entirely and I’m not sure this issue is confined to the custom user nodes it’s just that I can repeat it regularly there.

Other notes

  • Vuo version: 1.2.6-alpha1
  • macOS version: macOS 10.12
  • How severely does this bug affect you? It prevents me from completing a specific task with Vuo.

I reported this already in the Discussions Forum but after further testing today I am quite certain this is a bug.

This project I’m working on is critical to our June 8&9 Convocation Ceremonies. I’ve been working on this project for quite some time, all my testing was working beautifully, only recently as I started putting the pieces of this project together are things falling apart. Previous years I’ve done this project using QC however the 2011 MacBook Pro laptop I had used for that is no longer stable and I don’t have an alternative Mac with Lion installed that has the proper I/O ports for running the old composition so I have to make VUO work! Please help!

Mac Pro 2013 (6-core & D500 GPU)

Live Graphics (4.39 MB)


No Images.jpg

This appears to be the same underlying issue as Saving Composition to Node Library does not update relative file paths or copy files.

If you first made (Loyalist )ConvocationGUI.vuo as a regular top-level composition, the Fetch Image nodes would have worked fine because they were referencing image files relative to that composition file (like ../../../../Desktop/LC Convocation VUO Master/Image Elements/GUI_Buttons/Zoom Increase.png). If you then changed it to a subcomposition, (Loyalist )ConvocationGUI.vuo would have been moved to your User Modules folder, and it would then be looking for image files relative to the new location of the composition file — so it would no longer be able to find them.

As a workaround, you can edit the values of your Fetch Image nodes’ URL input ports, making them absolute paths instead of relative to the (sub)composition file. For example, change ../../../../Desktop/LC Convocation VUO Master/Image Elements/GUI_Buttons/Zoom Increase.png to ~/Desktop/LC Convocation VUO Master/Image Elements/GUI_Buttons/Zoom Increase.png. (The ~ is an abbreviation for /Users/[your username].)

OK, I see what happened there then. However per your advice I remapped the icons to the external drive location where the files will eventually reside which resolved that issue however now the lower buttons all disappeared… is this somehow related too?

GUI (61 KB)

@cwilms-loyalist, I’m seeing the same thing with the buttons disappearing. That is weird. I think it must be a separate issue since the buttons just have a label and a background color, no images or anything loaded from a file. If I just put a Make Button and a Render Layers to Window into a subcomposition, that works. The problem might be related to how events are coming into your subcomposition. I would suggest narrowing down the problem by either taking out pieces until it works or building it up from an empty subcomposition until it stops working. In general, if you’ve built up a lot of parts of a composition individually (as subcompositions or whatever), I’d suggest integrating them one by one rather than putting them together all at once, just because of the inherent difficulty of building complex systems (things that worked fine by themselves start revealing weird behaviors when they start being used in the context of a larger system).