Inconsistent video input size

Steps causing the bug to occur

  1. connect a Magewell USB capture HDMI gen 2 with a HDMI camera plugged into
  2. open the attached patch
  3. check “received frame” output pin: Size says 1980 x 1200
  4. Open Quicktime player
  5. Start new movie recording
  6. check again “received frame” output pin: Size says 1980 x 1080

Other notes

  • Vuo version: 1.2.5
  • macOS version: OS X 10.10
  • How severely does this bug affect you? It prevents me from completing a specific task with Vuo.

I0d expect it to be 1920 x 1080 at start

C920->Syphon.vuo (2.76 KB)

Senza titolo.jpg

It could be that your video source is providing non-square pixels, and Vuo handles them differently than QuickTime Player. When Vuo detects that the video source has non-square pixels, Vuo asks the video source to provide square pixels. Maybe that’s happening to begin with, and then QuickTime Player is asking the video source to switch back to non-square pixels.

We may send you a demo app to check if that is indeed the problem. Or if you know of some other way to check, let me know.

When I run the vuo app, the USBCaptureUtility set resolution to 1920x1200@60fps. When i run Quicktime, it set to 1920x1080@29.97fps.
I solved forcing the Magewell device to forget other resolution or fps than the needed one, setting the USBCaptureUtility app. In this way, Vuo also set the desired resolution and fps at start.  

Thanks for sharing your workaround.

In Vuo 1.2.7, we added Width and Height input ports to Receive Live Video, so now you can force a specific resolution without going through QuickTime Player.