Is it possible to disable the crash report dialog?


I’m experiencing some random crashes of a VUO composition. Since it doesn’t happen very often (can take several days to crash), I’ve set up a monitoring script that relaunches the composition if it dies.

So far so good… but there is a very annoying problem: sometimes the “crash report” dialog appears and it stays on top of everything, even if the newly launched composition is fullscreen.

So my question is: there is a way to disable the crash report window?

I don’t know how to disable a crash report window but did you try setting your window level to floating ? this should make the window stay on top of all the other normal windows even if the window isn’t focused. In theory if you set the window level to floating and go fullscreen any windows that pop up should happen below the floating fullscreen window. that’s the idea, however the question is if a crash report is considered a normal window or not, that I can’t test as I don’t know how to force a crash report out of my system.


Unfortunately no… the crash report window keeps itself on top, it doesn’t look like a normal window (maybe it is a floating window as well?)

I found a way to “force” a crash, just run the command:

killall -6 MyPlayer

in a terminal, where MyPlayer is the name of the running composition.

Thanks for the suggestion anyway!

oh that sucks. I wondered what happen if you have two floating windows open which one takes precedence. you could try maybe to build an app of your own using the image generator protocol and then go full screen to the NSScreenSaverWindowLevel in Xcode.

I think this screen saver level should go above all the other levels. sadly Vuo doesn’t give that option in its window leveling. maybe make a feature request ? would be something fairly easy for them to implement. I would think they are already sending to three levels. I would like to build an app fullscreen to the desktop level under everything. sort of make a screensaver for the desktop. I’m not sure if this is possible anymore, it used to be years ago.

maybe there is a way to appease the crash report window like your doing with your composition monitoring, do the same thing monitor for crash report and if it opens send the report which would close the crash report window ? I don’t know how you are monitoring your composition ? apple script maybe ? sounds fancy.

maybe easier just to turn off your analytics you can go to system preferences > security and turn off analytics so it stops sending crash reports to apple or the developers. this might appease the crash reporter.

or in this video the guy shows some terminal commands to disable the crash reporter all together or turn it into a notification window.

The command line in the video did not work (also the in the video the guy writes instead of I guess he did a typo, BTW in either case it didn’t work for me). Also disabling the option in the privacy panel seems to not prevent the dialog to appear (I had it already disabled).

Anyway, your answer made me think that this is a system-wide feature, so I searched better, and I found this answer on StackOverflow:

that finally led me to read the man page of CrashReport that says:

     launchtl can be used to disable and re-enable crash reporting.  To disable crash reporting:

           launchctl unload -w /System/Library/LaunchAgents/
           sudo launchctl unload -w /System/Library/LaunchDaemons/

     To re-enable crash reporting:

           launchctl load -w /System/Library/LaunchAgents/
           sudo launchctl load -w /System/Library/LaunchDaemons/

and indeed the commands:

launchctl unload -w /System/Library/LaunchAgents/
sudo launchctl unload -w /System/Library/LaunchDaemons/

successfully disabled the dialog! \o/ \o/

Thanks for your help!


that’s great you figured it out.

stackoverflow is your friend more often than not. I thought you might have tried that stuff already. in that stackoverflow thread right after the guy who suggested to read the man pages for crash reporter says that.

defaults write DialogType none

method seemed to work at some point prior to macOS 10.13. so that video although had typo at one point must have worked. sorry I should have tried it before I posted. I thought it would help. I’m going to try and disable my crash reporter with the commands you posted.

launchctl unload -w /System/Library/LaunchAgents/
sudo launchctl unload -w /System/Library/LaunchDaemons/

I find that crash reporter pesky and rarely helpful for me in sorting out bugs. its only helpful function for me is the reopen crashed app option.

Great that you found a solution, @cmaglie!

If you’d like to create a bug report for the crashes, we (Vuo team) would be happy to take a look. It’s often difficult to figure out a crash that’s rare and seemingly random, but there’s a chance we’d be able to make progress if we could see the crash reports and composition. You can find the crash reports in