Multichannel virtual audio device as input: only two channels in Vuo

Soundflower and Loopback are virtual audio devices for routing audio between applications and they can be multichannel (more than two channels).

When they are used in multichannel, Vuo only sees two channels and no audio signal is going into Vuo.

In the case of Loopback, if it’s set to multichannel and assigned to a real multichannel audio interface (tested with Metric Halo LIO-8 and RME Fireface UC), Vuo will see more than two channels and the audio signal will be going into Vuo. But again, if Loopback is set to multichannel and not assigned to a real audio interface (what could be called “true virtual mode”), only two silent channels are available in Vuo.

I tested with an audio editor, TwistedWave, and when Loopback is in “true virtual mode”, multichannel audio is received as such in TwistedWave and it can be recorded.


When Soundflower is installed, Vuo sees these options:

Soundflower audio devices.png

When you pick a device from Receive Live Audio’s input editor, it matches based on the device model. However, both the 2- and 64-channel Soundflower devices have the same model number, so that will always choose the 2-channel version since it’s listed first.

Since the models are the same but the names are unique, you can use Make Audio Input from Name to pick the 64-channel device. Example attached (64channel.vuo).


We installed and tested Loopback (in “true virtual mode”, using audio from iTunes), and Vuo is successfully receiving audio data from it for us.

Could you post your Loopback configuration and Vuo composition? Or try with the settings we used. Here’s what we tested with:


64channel.vuo (929 Bytes)

It seems the solution for Soundflower is also the solution for Loopback. Thanks!

1 Like