On Mac OS 10.9, if "Displays have separate Spaces" is disabled, multiple windows cannot go fullscreen

Steps causing the bug to occur

  1. In System Preferences > Mission Control, uncheck the “Displays have separate Spaces” checkbox (which is checked by default)
  2. Create a composition with 2 or more windows
  3. Move each window to a separate space and make it fullscreen

How did the result differ from what you expected?

Expect to be able to make multiple windows fullscreen simultaneously on separate screens

Have you found a workaround?

Check the “Displays have separate Spaces” checkbox

Other notes

  • Vuo version: 0.8.0
  • macOS version: OS X 10.9

(From @pbourke’s question.)

In Vuo 0.9.0, we stopped using the new (Mac OS 10.7+) fullscreen behavior, so now you can make multiple windows fullscreen even when “Displays have separate Spaces” is disabled.