Region preference sometimes overrides Language preference

Steps causing the bug to occur

  1. In System Preferences > Language & Region, set English as the first Preferred Language and German as the second Preferred Language, and set the Region to Germany.
  2. Launch Vuo-2.0.0-beta1.

The Vuo UI should be in English now since that’s the first Preferred Language. Instead, it’s in German.

Have you found a workaround?

in System Preferences > Language & Region > Preferred Languages, remove German. (But you can keep Region set to Germany.)

Fixed in Vuo 2.0.0-beta3.

Issue is still present in Vuo 2.0.2, workaround given above still works. So it seems the fix reported to work in 2.0.0-beta3 did not make it into 2.0.2.