Resolume crashes when changing the parameters of FFGL


I’m using “Explode Sphere.vuo” in the example file for testing FFGL for Resolume.

I published to Port “Rows” and “Columns” from the “Make Sphere” node in the Vuo composition,

exported it in FFGL, loaded it into Resolume, and tried several operations.

But, Resolume crashes when I try to change the parameter of “Columns”.

(The parameter of “Rows” can be changed smoothly without any problem!)

How can I solve it?

Thank you.

OS version : 10.15.4

Vuo version : 2.0.2(r37282, build 11255)

Resolume version : Arena 7.1.2 rev69101

I tried replacing the “Make Sphere” node with a “Make 3D Square” node, and export to FFGL, I got exactly the same problem…

I have just built and exported Explode sphere and tested in Resolume 6, it worked fine.
Seems weird that just one parameter would cause an issue.
Attached the comp and FF I made.

explode sphere reso (2.6 MB)

Thank you, Joe!

I immediately tried using your plugin with Resolume 6 (the latest trial version).
It has certainly worked in R6 without any problems.
But (unfortunately), even the one I exported works perfectly in R6…
(Just in case, I’ve uploaded my FFGL.)
By the way, in R7, your plugin crashed with the same operation too.

Most of the other self-built plugins I’ve written using Vuo working perfectly in R7.
In other words, this specific feature may not work well in R7. (2.61 MB)

We have been in correspondence with Resolume. They told us, “The issue is that we’re not able to handle a parameter called ‘Columns’. I’ll create a ticket for this, but maybe in the meantime your user can rename the parameter?”

Thank you for your reply.
I just renamed the parameters from “Columns” to “Column”,
and it worked perfectly in Resolume Arena 7.
Thank you very much for your help!