Serial ports - find by name not working

Steps causing the bug to occur

  1. Feed “list serial devices” into “find serial device by name”, empty list.

Have you found a workaround?

I’m lucky, there is only one serial device found.

Other notes

  • Vuo version: 2.4.2
  • macOS version: macOS 12
  • CPU: arm64
  • Have you been able to reproduce the problem? Yes, the problem occurs consistently when I follow the steps above
  • How severely does this bug affect you? Not much; I’m just letting you know about it.

I attach a screen capture showing the effect.
Please note that I use these nodes on my Intel MacMini (same OS and Vuo versions) and it works fine.
Not sure it is an M1 thing or the different serial device being used.

% ls -l /dev | grep usb

crw-rw-rw- 1 root wheel 0x9000003 Mar 1 17:36 cu.usbmodem8301

crw-rw-rw- 1 root wheel 0x9000002 Mar 1 17:30 tty.usbmodem8301

ps: I’m also getting occasional crashes doing serial communications, I’ll send another bug report when I’ve tried to further isolate the cause.

good session.log (4.69 KB)

Screenshot 2023-03-02 at 7.01.14 AM.png

See my next bug report on the composition loader crashing if I ignore incoming serial data.  

You’re connecting to a device named Arduino ( Generic CDC and searching for port name Arduino. The reason it doesn’t work is that Find Serial Devices by Name uses wildcard matching and requires that the search term matches the full text of the name. So you should be able to find your device by changing Find Serial Devices by Name’s Name to Arduino*.

I can see how this would be confusing (I didn’t immediately spot the problem either). There is a good reason for it being implemented the way it is, with the full-text wildcard matching: if you have two devices, one having a name that is a subset of the other one’s name, then Find Serial Devices by Name can distinguish between them. Since it’s not directly a bug, I’ll close this bug report, but make an internal note that we could clarify the documentation or port name.

OK, I’ll try that and it makes sense.
But it doesn’t explain the attached which I’ve used in a few projects, I had assumed it was searching for the string anywhere in the name.
In the past I used to specify “Keyspan” and it worked, I changed to “division” in this example just to make the point.

While I don’t really understand why there is a difference between my use of the “Find srial device by name” the the previous message and now, but I can firm that using the wildcard specification is working for me. Is it possibly a difference between the old and pre-release version you sent me? In any case, thanks for looking into it and I’m happy it’s all working.

Well, it’s because the two nodes are inconsistent with each other, which is not ideal for usability. We’re using wildcard matching with the newer node classes but haven’t gone back and updated all of the old ones yet. Anyway, glad to hear the wildcard specification is working for Find Serial Devices by Name.

(I’ve deleted the comment you flagged as a duplicate.)

In Vuo 2.4.3, we clarified the documentation about wildcard matching for Find * by Name nodes.