URL schema in "Save Images to Movie" not working

Steps causing the bug to occur

Hello, I just played around with your “SaveImage.vuo” example composition. I tried to change it, so it works with saving a movie instead of an image. I found out that “Display Save Window” always puts out an absolute path. But whenever I input an absolute URL into the input port of “Save Images to movie” the file will not be saved. Only with relative paths can I get the movie to be saved. I tried both on a Monterey and a Catalina System with the latest VUO 2.4.1. Is this a permissions related problem? How can I save a movie with absolute URLs?

Other notes

  • Vuo version: 2.4.1
  • Have you been able to reproduce the problem? Yes, the problem occurs consistently when I follow the steps above
  • How severely does this bug affect you? It prevents me from completing a specific task with Vuo.


Thanks for mentioning this. It’s not a path or permissions problem. We’ve verified that there is a problem with the URL schema in Save Images to Movie, so we converted your discussion to a bug report.

You can use Get File URL Values’s Path output as a temporary workaround (like in SaveMovie.vuo).

SaveMovie.vuo (4.99 KB)

Fixed in Vuo 2.4.2.