Vuo compositions not loaded in VDMX

Steps causing the bug to occur

  1. After updating to Vuo 2.0 my vuo files do not load in Vdmx. I have replaced the old deprecated ‘Render scene to image’ nodes to version2.0 as recommended. Cleared the Vuo cache in Vdmx.

  2. As my files contain many 3d object nodes (that were already giving me problems in the past), I made a simplest file just rendering a layer just to see, but still get the same message ‘There was a problem loading composition’.

  3. When I try to trigger vuo 1.2.8 files (with old deprecated nodes) Vdmx loads them fine. Only the Vuo 2.0 are affected.


Have you found a workaround?

Only going back to 1.2.8 files

Other notes

  • Vuo version: 2.0.0-beta2
  • macOS version: macOS 10.12
  • How severely does this bug affect you? It prevents me from using Vuo at all.

I’m on the latest VDMX Version b0.

The VDMX developers haven’t yet updated VDMX to work with Vuo 2.0.0 since it’s still in beta. They’re planning to do so when there’s a stable Vuo 2.0.0 release.

As you saw, one workaround would be to continue using Vuo 1.2.8 when building compositions for VDMX.

Another workaround (with Vuo Pro 2.0.0 beta) would be to export your compositions as FFGL plugins and load them into VDMX that way.

After installing the latest version of vdmx updated for use with vuo 2, vdmx kept crashing constantly, i couldn’t even open it. So I tried to move the whole vuo folder to another destination and out of sudden it opened. Than with manual relinking one by one I isolated all the vuo files that made vdmx crash and found out that all of them had in common ‘Make fisheye camera’ node. After taking that node out I was able to open vdmx again. It worked fine for like one afternoon, I re-opened and closed it for a few times, but than ouf of sudden I couldn’t open it again.
Every time i try to open vdmx, it freezes.
So i took out some 3rd party nodes(karlhenkel) from my vuo compositions (just in case, even though before they were not giving problems) and I was able to open vdmx few times and than nothing again.
I passed the same files (vdmx/vuo) to my laptop too and same thing, it wouldn’t open. I don’t know whats going, there is something strange with Make fisheye camera node maybe? Is anybody else experiencing same problems too? I have all of my vuo files updated as it was recommended and replaced all the deprecated nodes with the new ones.  


Thanks so much for troubleshooting your problem. That really helps us! Sorry you are having this problem. We believe your bug is the same as VDMX crash if I have “Warp Image with Projection Mesh” in my vuoFX. Some Vuo Pro nodes are not working correctly in VDMX. We will fix this in our next release, and then VIDVOX will need to update their app. I’m merging your bug with that one.