Vuo crashing when making sub composition

Steps causing the bug to occur

  1. Select nodes
  2. Control click selected nodes
  3. Select “Package as Subcomposition”

Other notes

  • Vuo version: 2.2.0
  • macOS version: macOS 10.14

Vuo_2020-11-23-215556_OFMBP15.crash (120 KB)


We appreciate you sending the crash report, but we weren’t able to diagnose this from the report. Is this happening reliably for you? If so, can you send us the composition and the nodes you were trying to package when this happens?

We’re marking this closed since we can’t reproduce it, but will reopen it if you or another community member can provide more information.

Hi, Vuo crashes if I make any sort of subComposition. Screen recording below:

Thanks for providing more information. We followed the steps shown in his screen recording (using the same nodes and the same top-level composition name and subcomposition name), but it doesn’t crash for us. We think it’s related to a third-party node or nodes that you have installed.

Does it help if you uninstall Parabox (and/or any other 3rd-party nodes you have installed)? Does it help if you temporarily rename your Modules folder on the Desktop? If so, can you narrow down which 3rd-party node or modules causes Vuo to crash, and send it to us so we can try to diagnose the problem?

1 Like

Hi Jean,

I renamed my user 3rd party nodes (~/Library/Application Support/Vuo/modules_bak) and tried again following the steps in the video. But the same issue occurred, I’ve attached the crash log.

201216-1408_Vuo-Crash-Log.txt (120 KB)

Have you tried renaming the Modules folder on the Desktop? If that fixes it, you can send us that folder so we can see what’s amiss.

Hi Jean,

I created a new project using the same steps but this time saving into a new directory. Same crash as before, the files are attached. (2.02 KB)

Aha, the key to reproducing it (which is in fact shown in your video) is to detach the node library from the editor window. We’ll have a fix in the next release.

1 Like

Yes, that works! I wouldn’t have worked that one out. Cheers :-)

Fixed in Vuo 2.2.1.