Vuo-Made FCPX Transition Won't Render in Compressor

Steps causing the bug to occur

  1. Create a Transition from template - Image or FxPlug (tried both based on Vuo tutorial)
  2. Export to FCPX
  3. It works in FCPX, but rendering with Compressor fails, generating an error, “Failed: Error: RenderFrameAt returned: 4 for absolute frame: 996” Frame 996 is the beginning of the Vuo-made transition in my case.

Have you found a workaround?

I can render directly with FCPX, but I use Compressor to get the file type/size I prefer.

Other notes

  • Vuo version: 2.3.0
  • macOS version: macOS 10.15
  • CPU: x86_64
  • How severely does this bug affect you? It’s annoying but I can work around it.

I built the transition twice from templates using the Protocol → image transition and the FxPlug → transition templates.

I opened the transition in Motion (from FCPX).

  • It generates an error about two missing media items (they are each half of the transition - seem to represent the start and ending clips?
  • Saved the transition, it removes the missing item references
  • The transition behaves the same in FCPX afterwards, but generates the same error in Compressor

Thanks for any help, Andrew

OS 10.15.7 Vuo FCPX 10.5.2 Compressor 4.5.2 Motion 5.5.1

FCPX Bulge Transition.vuo (7.62 KB)

1 Like

We were able to reproduce this and are working on a fix.

1 Like

Fixed in Vuo 2.4.0.