Vuo sends all OSC out messages 3 times.

Steps causing the bug to occur

  1. Create any minimal setup to send OSC messages with Vuo (my example composition is attached)
  2. Open some other application to see what messages Vuo sends (I have tested with Osculator and with VDMX)
  3. All messages sent from Vuo comes 3 times to receiving application

Have you found a workaround?


Other notes

  • Vuo version: 1.2.6
  • macOS version: OS X 10.11
  • How severely does this bug affect you? It’s annoying but I can work around it.

You can see from my screenshot, there is minimal example composition which sends one number to OSC output when screen is clicked. (There is input console of Osculator open, which shows all incoming OSC messages with time stamps. So all numbers coming from Vuo, comes 3 times with almost same time stamp. (So, before that screenshot I have clicked 3 times, but 9 messages have been sent). I have tested same with VDMX and with couple of much more complex OSC out compositions, but now I just narrowed this down to find a reason why my OSC “bus” is so full of messages.

This is annoying, but I don’t know how to work around it. I have problem with too much OSC traffic which makes, my OSC receiving VDMX behave less responsive, so fixing this bug would cut the traffic to third.

VuoOscOutBug.vuo (4.14 KB)


@timwessman, we tried reproducing the problem here but it worked OK, so apparently there’s something different about your system.

We tested running your test composition, first with Osculator and then with OSCTestApp from VIDVOX. In both cases, each click in the composition resulted in one message received by Osculator or OSCTestApp.

Your composition looks OK.

Is it possible that some other OSC device/software on your network is echoing the messages?

Very interesting…thanks for testing this.

I made now a new version of my test composition to have also Receive OSC Message and Display Console Window. If I reboot my machine and run only this application I get same result (every message 3 times). Maybe some part of my network is echoing traffic in general (not OSC related thing?). …so I tested to turn of wifi, voila, now I get messages echoed only twice (so some improvement).

I will test this with different machines and let you know if I find something. Thanks, you helped me forward with this one.

VuoOscOutBug2.vuo (5.26 KB)

I changed Make OSC Output -node to Make OSC IP Output -node, to send only to localhost ( Now OSC messages are sent only once.

Help of Make OSC Output -node says that it sends messages to all devices. I made List OSC Devices -node to see what are those all devices, at least for me Vuo shows two devices when only my VuoOscOutBug3.vuo composition is running.

Vuo OSC Clientreceiving from port 4444
Vuo OSC Clientreceiving from port 4444

Is this because of some loop in my network, maybe? Anyway I’m now happy that I can use Make OSC IP Output -node with localhost to solve my problem and send only single messages

VuoOscOutBug3.vuo (6.81 KB)

@timwessman, sorry for the tardy reply.

Your system seems to have multiple local network interfaces (192.168.* and 172.*). That might be because it has both wifi and wired ethernet connected at the same time, or because you’re connected to a VPN, or have a VM running, or because you have Thunderbolt or Firewire or Bluetooth or USB networking enabled, or something. Under System Preferences > Network, all the green dots are active network interfaces.

Vuo 1.2.6’s OSC Broadcast mode (Make OSC Output) sends to all the network interfaces, to improve the chance of the message getting through to where you want it. If the receiving end is also listening on each of the multiple network interfaces, then it will receive the OSC message on each of those interfaces.

So the correct setup, as you figured out, would be to use Make OSC IP Output, which will only send to a single network interface.