`Spike 3D Object` loses the object's texture coordinates

Steps causing the bug to occur


Has the behaviour of the 3d nodes changed in vuo2? For example ‘Spike 3d object’ in vuo1 reads the texture correctly and when the effect is applied it spikes the object with the texture applied.
But in vuo2 the same composition doesn’t ‘recognize’ the texture the same way and even with the value 0 in ‘Spike effect’ it doesnt load it. When I take the effect out, it’s fine. Is this the way it’s meant to work? Or has something been changed?
First 2 photos are from vuo1 composition and second 2 from the same composition but ran in vuo2.

Other notes

  • Vuo version: 2.0.2
  • How severely does this bug affect you? It prevents me from completing a specific task with Vuo.

Ran some tests comparing 3D filters in Vuo 128 & 202.
On my iMac mid 2011 with AMD Radeon HD 6750M, here is what I get :

  • Displace 3D Object with image

    • Vuo 1 : Fine
    • Vuo 2 : Lightning flickers, choppy animation
  • Spike 3D Object

    • Vuo 1 : Ok
    • Vuo 2 : Shaded with unlit images it looses the texture & triangles glitch, same for lit color shaders
  • Quantize 3D Object

    • Vuo 1 : Rotates a 3D Plane by 90° on the X axis, or for a sphere, the object appears bigger than it is.
    • Vuo 2 : Ok, so fixed in Vuo 2
  • Vuo 1 & 2 the same

    • Add Noise to 3D Object
    • Explode 3D Object
    • Pinch 3D Object
    • Twirl 3D Object
    • Skew 3D Object
    • Facet 3D Object
    • Bend 3D Object
    • Divide 3D Object

So the textures load fine it seems, it’s that with “Spike 3D Object” they disappear & glitch.
Joined are the sample test compostions, with draggable cameras to allow to move around the scene.  

Tests.zip (13 KB)

1 Like


We’ve turned your disucssion into a bug report and accepted it. In Vuo 2.0.3, Spike 3D Object appears to lose the texture coordinates. We’ll look at this in conjunction with changes as Vuo’s graphics go from OpenGL to Metal. As noted, Spike 3D Object works correctly in 1.2.8.  

Thank you for checking Jean Marie.
Could you also see / reproduce the issue with Displace 3D Object with image ?

Ok, thanks. As you mention Vuo going from OpenGL to Metal, is there any aprox. timeline on this?
I still cannot run Vuo on my laptop due to this submitted bug two years ago:
( I have to create stuff on my desktop and than pre-record the compositions for my vj session turning them into QT, so Im loosing all the real time interactivity)
So I’m still waiting for the solution for this. I have been told that would be probably solved by moving to Metal. Would that be any update soon?


We reproduced some slight flickering for Displace 3D Object with Image, but not the choppiness. Maybe the difference was due the system we tested it on. Again, we’ll revisit in conjunction with our move to Metal.

1 Like


In Vuo 2.0, we changed 3D object filters so they run on the CPU. We think this may fix the glitches you were experiencing — please test and let us know. (We overlooked leaving a comment on https://community.vuo.org/t/-/6120 after that work.)

When testing in VDMX, make sure your version of VDMX includes the Vuo 2.0 framework, available from https://discourse.vidvox.net/t/new-vdmx-update-with-vuo-2-0-support/1092 .

We are actively working on the transition to Metal, but we don’t have a release date at this time.

I always test it after each update and on all of them it’s still the same. I seems like it’s getting worse. With vuo 2.0.3 installed vdmx goes crazy as soon as I open it. Before it allowed me at least to play simple compositions and it only gave glitches and errors when i tried to play compositions containing 3d nodes but now as sonn as i open vdmx, it doesnt even let me click on anything, the whole screen goes glitching.


Here’s a few things you might consider:

  • In order for Vuo image filters and generators to work in VDMX, VDMX has to bundle its own version of Vuo within VDMX. The VDMX release that supports Vuo 2.0 is listed at https://discourse.vidvox.net/t/new-vdmx-update-with-vuo-2-0-support/1092. You will need to download and install that version (or a later version) of VDMX in order to use Vuo 2.0’s CPU-based 3D object filters, which should be less crashy/glitchy.
  • Is it possible that VDMX is not working correctly on your system? Try removing your VDMX support folder — in Finder, hold Option and select Go > Library, then navigate to Application Support, and put the VDMX folder in the Trash. Then launch VDMX — does VDMX work properly now?
  • Another thing to try is to export your Vuo composition as a FFGL plug-in, and follow the directions here: https://vdmx.vidvox.net/tutorials/installing-and-using-freeframe-and-ffgl. Do you still encounter the same problems?

We hope those suggestions will be helpful. Please let us know if any of them work for you.

Yes, I’m aware of that. So I always wait first untill David releases the new update of VDMX with new bundled vuo version. Than I do the tests. But it always gave erros/glitches. Right now I’m on the vdmx b8.7.2.3.dmg( the link you have send) since it came out. This specific version was giving me more problems, not even letting the vdmx to open.It crashes straight away. ( I reported the bug here on 25th of april: https://community.vuo.org/t/-/6363)
I think that was still on vuo 2.0.2 and the 2.0.3 update came few weeks later, so Im waiting for the new vdmx update to see if it will be fixed ( at this moment I cannot open vdmx, it crashes at the start)
Im not sure about vdmx not working properly…I have been using more than 10 years and it was always stable and never gave problems (some minor ones): Both on laptop and desktop runs smooth so I think it’s something vuo related as it is giving problems since I started to use vuo comps.
I didnt try yet trashing vdmx folder…would that delete my inner vdmx project settings?

Mora, try an FFGL as suggested, maybe that won’t glitch crash until VDMX updates to latest Vuo or Metal Implementation.
But Spike 3D Object will still loose the textures however I guess.  

I didnt try yet trashing vdmx folder…would that delete my inner vdmx project settings?

You could temporarily move it to your desktop, so you could move it back after testing. Alternatively, you could only remove the Vuo-related folders:

  • plugins
  • VuoCache
  • vuoFX
  • vuoSources
  • vuoTextSources

Hi Christian, Im busy finishing a 3D project now but when I have a moment I will try the FFGL to know at least if it works. Thanks!

I just posted about a similar behaviour, with the 3D displacement: https://community.vuo.org/t/-/6587

On VUO 128 looks fine, on VUO 2 looks glitchy and specially it gets really slow.
Is there anything I can do? specially related to the performance thing?


Ok, so this issue was solved on M1 Macbook and the textures were shown correctly. Than on my new Mac Studio M2 the glitch came back again. I have reported that last year ( I cannot find the link now). I was told that on a different hardware ( even a newer one) the behaviour could be different) which I understand.
But now on my M1 when using vdmx everything works fine but when I download the latest version the glitch is back on. I don’t understand at all. Same computer, same vuo version but different behaviour depending on vdmx version. Shouldn’t this be other way around? The new vdmx version is supossed to have bundle the leatest vuo. When I open the composition in vuo, all works fine, than depending on vdmx version i get different behaviour. Would this be a vdmx error? … but than I get the glitch on the latest version which forces me to stay on the older one. Would anybody know why this is happening?
Thank you