VDMX not remembering MIDI Mapping

Steps causing the bug to occur

  1. In VDMX on a Vuo comp with published sliders, press CMD L or via the menu Hardware Learn Toggle
  2. MIDI map some sliders (I’m using Lemur for iPad)
  3. Eject composition and load in again - forgets MIDI mapping after 2nd time or so of loading in the comp

Have you found a workaround?


Other notes

  • Vuo version: 2.0.3
  • macOS version: macOS 10.13
  • How severely does this bug affect you? It prevents me from completing a specific task with Vuo.

I tried a second manual method of adding and detecting a source via the Inspector in VDMX. This seems to remember it, I will stress test that method now. However on closing and reopening VDMX, the MIDI mapping is forgotten again. Attached 2 videos (the second one shows VDMX reopening without the MIDI mapping - Quicktime was struggling to screen capture in one go)

I attached a zip of the videos in the composition field below as there wasn’t a place to attach videos.

VDMX version b0.

VDMX_MIDI.zip (77.1 MB)

Adding the MIDI mapping via the Inspector (attached) worked for a while, ejecting and loading in the composition during a visual mix, but on some random load of the comp, it was forgotten again.

Since the MIDI mappings are implemented on the VDMX side rather than the Vuo side, we think the fix would have to be implemented by the VDMX developers. We’ve sent them a link to your bug report. We’ll let you know if we hear back from them.